Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 14 Current »

Affected version(s): 7.8.4-rev28

Currently set to expired. If team agrees to set valid page again, remove this and page will be updated with a valid OK status


Problem

After updating to middleware version 7.8.4-Rev28, access to S3 storage systems doesn't work anymore. During startup of the middleware you see error messages like the following:

CFG-0007 Categories=CONFIGURATION Message='Invalid configuration: Neither "com.openexchange.filestore.s3.[variable]..ecretKey"nor "com.openexchange.filestore.s3.default..ecretKey" is specified'

Root-Cause:

A problem in the S3 bundle (open-xchange-filestore-s3) prevents reading the correct configuration values, searching instead for the following:

com.openexchange.filestore.s3.default..ecretKey

(note the "." instead of "s" in secretKey")

Workaround

1. Check all properties in your configuration dealing with S3 connectors having the names:

com.openexchange.filestore.s3.[filestoreID].secretKey   (where filestoreID is your local configuration identifier)

2. Change the names of those properties and replace the suffix .secretKey with ..ecretKey and restart the middleware afterwards

Note the double "."

For convenience, you may wish to keep the old copy saved outside of the App Suite configuration directory. You will need to restore it, and remove the workaround when you deploy the fixed release.

Solution

Tracked as Bug #58322

STATUS: Fixed and released with 7.8.4-Rev29 and higher.

Release Notes

  • No labels